Online: GGUser260, paulybronco, evo94

Just bought me first Ultraglide

  • blacky
    blacky
    24 days ago
     Its an 08 with 71k on the clock , rides well and everything seems to work OK but I cant get any sound out of the stereo, the previous owner had it for 18 months and said it only ever worked once in all the time he had it - had a quick look online and the most common drama seems to be the head unit itself , any of you mob have trouble with yours ? It lights up and you can program stations, seek works etc, just no sound ?
  • blacky
    blacky
    24 days ago
     Found this spring in front of the numberplate mount , any clues what its for ????   Also these plastic covers , I think the seller said they were some kind of cooling aid for the engine ??
  • steelo
    steelo
    24 days ago
    Get a stereo instruction manual blacky. I’d say the sound output has been directed to headset ( that plug on tank) instead of speakers. It’s a setting. (At least in later boom stereo)
    Nice bike. Black too!
  • fatbat
    fatbat
    23 days ago
    Those radio units fail. There’s a shop in the USA that repairs them and also does other upgrades to them so you can plug your phone into them for music etc but it wouldn’t be worth it.  Get a good aftermarket head unit. 

    In any event the best way of listening to music/radio in terms of sound quality and not destroying your hearing are ear moulded headphones. 

    Good luck 
  • paulybronco
    paulybronco
    23 days ago
    Quoting blacky on 12 Nov 2021 01:38 PM

     Found this spring in front of the numberplate mount , any clues what its for ????   Also these plastic covers , I think the seller said they were some kind of cooling aid for the engine ??

    They are heat deflectors. Best bit of plastic to stop the heat boiling your balls off. Oh yes should point out they bolt to the frame, not to tape them to your nuts!
    The radio is sounding Foooked....have had two, first under warranty second from my mate who replaced his with a aftermarket. They had plenty of terminal issues.
  • blacky
    blacky
    23 days ago
     Cheers Pauly , I was looking further forward, thought he meant they directed air onto the motor, not away from your nuts :-) There is a cable hanging out there that is used to unlatch the riders backrest - the rest of it is broken, might have to go and spend a few bucks on some overpriced genuine bits this morning
  • paulybronco
    paulybronco
    23 days ago
    Quoting blacky on 13 Nov 2021 01:04 AM

     Cheers Pauly , I was looking further forward, thought he meant they directed air onto the motor, not away from your nuts :-) There is a cable hanging out there that is used to unlatch the riders backrest - the rest of it is broken, might have to go and spend a few bucks on some overpriced genuine bits this morning

    They kinda do both.....directing air to the motor while moving and directing it away from you at idle, traffic stops etc. The later models have a idle control that shuts down the rear cyl when idling to prevent the heat increase, yours is before that feature sadly. Paint your radio green and throw it in the long grass, they are not a great thing at all.
  • blacky
    blacky
    23 days ago
    Quoting blacky on 13 Nov 2021 01:04 AM

     Cheers Pauly , I was looking further forward, thought he meant they directed air onto the motor, not away from your nuts :-) There is a cable hanging out there that is used to unlatch the riders backrest - the rest of it is broken, might have to go and spend a few bucks on some overpriced genuine bits this morning

    Quoting paulybronco on 13 Nov 2021 01:24 AM

    They kinda do both.....directing air to the motor while moving and directing it away from you at idle, traffic stops etc. The later models have a idle control that shuts down the rear cyl when idling to prevent the heat increase, yours is before that feature sadly. Paint your radio green and throw it in the long grass, they are not a great thing at all.

     I was hoping to keep the stock radio , unless an aftermarket one is compatible with the handlebar controls and all the other shit ?
     Sorted a few minor dramas with it today - removed the towbar and while the panniers were off realised the crash bars were on the piss , and sorted out the spring mystery.I don't think the rear wheel has been cleaned since the fucker was new ...... what do you use to clean these rims ? My FXR has chrome wheels.

    I need 2 new tyres and  a cush drive , I am in Perth , any recommendations ???


  • blacky
    blacky
    23 days ago
     Cleaned up , spent the arvo polishing in the shed

  • blacky
    blacky
    23 days ago
     just came in and posted these pics then remembered about the radio diagnostic post , went back out the shed and ran a test , it threw a B2017 code - something to do with the front speakers - i hit the end diagnostic button and I had tunes !!! Happy days ....
  • fatbat
    fatbat
    23 days ago
    Well done getting the stereo to work. 

    If you do ever want to swap it for something better, there are options for keeping the handlebar controls. A few years ago I upgraded the stereo to a Sony mex-70bt Bluetooth and usb head unit fully controlled by oem thumb controls. Also rigged it up to an amp and upgraded the speakers. As good as the stereo was, you can’t beat good ear moulded headphones 
  • keith
    keith
    22 days ago
    https://www.bikedoctor.com.au for your tyres.
    Mr Muscle oven cleaner on the rims, might bring them back a bit.?
  • tussuck
    tussuck
    20 days ago
    Quoting keith on 13 Nov 2021 10:56 PM

    https://www.bikedoctor.com.au for your tyres.

    Mr Muscle oven cleaner on the rims, might bring them back a bit.?

    Yeah, pull the rear wheel off and get some heavy duty alloy wheel cleaner (make SURE its for alloy wheels or it will damage the rims).
    Then its a cut and buff with Autosol or S100 from the delaer.

  • blacky
    blacky
    18 days ago
     Thanks fellas, found a couple of things i will need to sort out - the stereo works most of the time, it cuts out randomly but if you move the speaker switch it seems to fix it - guessing (hoping) its just a dicky switch , will yank it out and try to clean it up or replace it. The fuel gauge and volt gauge backlights don't work , can check them while I am in there.

     What does the accessory switch do ? is it just there for a spare ??

     The steering lock doesn't work either, the whole thing is pretty sticky , as if it never got used. I squirted a bit of Lanotec in there and now the key moves freely but I can't get it to lock - any ideas ???
  • Neale
    Neale
    17 days ago
    Hi mate.
    I have an 08 Electra Glide Standard that I bought new. It has 120,000 kms on it so far.
    Just wondering if you are interested in knowing what’s worn out ?
  • paulybronco
    paulybronco
    17 days ago
    Quoting Neale on 19 Nov 2021 09:29 AM

    Hi mate.

    I have an 08 Electra Glide Standard that I bought new. It has 120,000 kms on it so far.
    Just wondering if you are interested in knowing what’s worn out ?

    If the answer is the rider do i win a prize....
  • Far Canal
    Far Canal
    15 days ago
    Quoting Neale on 19 Nov 2021 09:29 AM

    Hi mate.

    I have an 08 Electra Glide Standard that I bought new. It has 120,000 kms on it so far.
    Just wondering if you are interested in knowing what’s worn out ?

    I would be interested to hear what has worn out on it Neale in the 120,000kms. Not so much tyres but mechanical stuff etc.
  • paulybronco
    paulybronco
    14 days ago
    Quoting Neale on 19 Nov 2021 09:29 AM

    Hi mate.

    I have an 08 Electra Glide Standard that I bought new. It has 120,000 kms on it so far.
    Just wondering if you are interested in knowing what’s worn out ?

    Quoting Far Canal on 21 Nov 2021 04:31 AM

    I would be interested to hear what has worn out on it Neale in the 120,000kms. Not so much tyres but mechanical stuff etc.

    Seems like i have won the prize....Neale is that worn out he forgot to answer!